We support the following browsers: IE (9+), Firefox (3.6+), Safari (5+) & Chrome (latest)